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ABSTRACT

This User’s Guide for the International Space Station (ISS) Payload Data Library (PDL)
provides information necessary to use the PDL application.  It includes an overview of the PDL
architecture as well as system requirements for the different platforms supported.  Guidelines are
provided for payload breakdown components, payload IDs, the schedule of data entry, and data
distribution.  Finally, instructions are given to assist the User in navigating PDL and entering data.
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SECTION 1,  INTRODUCTION

1.1 SYSTEM OVERVIEW

The Payload Data Library (PDL) is an electronic database system developed to support
the Engineering and Operations Integration (E&OI) personnel in collecting and managing
payload data.  The primary function of PDL is to provide a convenient method for collection,
processing, managing, and distribution of payload information necessary for payload
complement integration and for preparation of integration requirements reports.  PDL is
configured as a Client–Server system utilizing Oracle software and is accessible to the user via
the Internet. The user may download this software, as well as obtain a User Account and
Password, by accessing the PDL Home Page on the World Wide Web (WWW) at
http://pdl.msfc.nasa.gov.  Interfacing between PDL and other ISS databases is accomplished
by using data file transfers over various data networks.

1.2 SYSTEM REQUIREMENTS

The PDL Client software is compatible with Windows 3.1x, Windows ’95, Windows
NT, Mac PowerPC, and Unix/Motif workstations.   Downloading the PDL Client provides all
software needed to perform an installation of the PDL.

1.2.1 Windows

The PDL Client will run on an IBM–PC compatible computer running Windows 3.1,
Windows NT, or Windows ’95.   A minimum system configuration to run this software is a
80486 processor (25 MHz), 16 MB RAM, 640 x 480 resolution color monitor with 16 colors,
and 30 MB of available disk space. The PDL software operation cannot be guaranteed if your
system does not meet these minimum requirements.

1.2.2 Macintosh – PowerPC

A minimum system configuration to run this software is a PowerPC processor, 16 MB
RAM, a 832 x 624 resolution color monitor, and 40 MB of available disk space. The PDL
software operation cannot be guaranteed if your system does not meet these minimum
requirements.

1.2.3 Unix/Motif

TBD
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1.3 CLIENT–SERVER TECHNOLOGY USED IN PDL

The PDL database uses Client–Server technology to implement a user–friendly, quick–
response data collection and management system. Figure 1–1 depicts the PDL Client–Server
configuration.  Although a detailed understanding of this technology is not necessary to use the
PDL, you may find the following information useful.

The Server portion of the PDL system is a Sun Ultra Server 1 Model 140 located at the
George C. Marshall Space Flight Center (MSFC) in Huntsville, Alabama.  The Oracle
Relational Database Management System (RDBMS) runs on this server and will be kept up to
date with the latest version of the database.  The data that you enter into the PDL will be stored,
managed, distributed, and archived on this server.  Daily automated backups will ensure that
your data is not lost as the result of any anomaly in server operations.

The Client portion of the PDL system is an application that you download from the
PDL Home Page on the Web.  Every effort has been made to make the PDL Client available on
as many different platforms as possible.  Once downloaded, the PDL Client application resides
on your computer’s hard drive and may be launched by double–clicking the PDL Client icon
and then entering your User ID and Password.  Your computer is then connected to the PDL
server.  The Client application will allow you to retrieve and update data stored on the server.
To ensure that the latest data is available to all users, no data is stored on your local computer.

FileEdit Discipline Option Form Help

wPDL Application Developed using Oracle Forms
wSQL*NET-TCP/IP

Cancel Clear Update HelpNext

Oracle RDBMS

wPDL Relational Tables
wSQL*NET - TCP/IP

DATAINPUT/VIEW FORM

Server
Client FileEdit Help

Laboratory Support Equipment

w Solaris UNIX
w PC
w Power PC

w Sun Ultra Server

FIGURE 11  CLIENT-SERVER TECHNOLOGY IN THE PDL

Internet

Internet
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1.4 USER REQUIREMENTS

The PDL Client application utilizes a Graphical User Interface (GUI) to provide an easy
and consistent means of manipulating data; however, an understanding of the following
functions associated with a GUI is required:

A. Locating and launching programs from the desktop

B. Using a mouse

C. Using a pull–down menu

D. Using system browsers for navigation to graphic files for upload into the PDL.
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SECTION 2,  GUIDELINES

2.1 PAYLOAD BREAKDOWN COMPONENTS

Space Station payload data is divided into disciplines within PDL for easy navigation.
Figure 2–1 depicts an example of the payload discipline breakdown components.

Payload

Contacts
Support Equip.
Power Req.
Circuit Protection
EMI

LSE

Discipline Menu

Options Menu

SPOE Items

Forms Menu

FIGURE 21  PAYLOAD BREAKDOWN COMPONENTS

C&DH
Electrical
Environmental Control
Systems
Training
On-Board Ops
Etc.

2.2 PAYLOAD IDS

The PDL uses the parameter format specified by the User Mission Database (UMDB)
for payload identification number definition.  The UMDB parameter format is:

AAnnn.mmB

AA–  This is the two letter code that represents the payload owner.  The first digit
specifically represents the partner (N = NASA, J = NASDA, E = ESA, C = CSA), and
the second digit specifically represents the organization (C = Commercial, for
example).  So ESA, Commercial organization, would be EC for the first two digits.

nnn– This is a three digit number, generated automatically by the UMDB, which
represents the ‘nth’ payload of this type.  So the first payload of type EC would be
EC001; the second would be EC002, etc.

mm– This is a two digit number, generated automatically by the UMDB, which
represents a subpayload.  The first time a payload record is created, this number is 00.
If another subpayload is created in the UMDB, then a new payload record is created
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with the same payload ID, but this number is incremented by one to 01.  The next
subpayload created in the UMDB will be 02.

B– This one digit character can be one of the following:  “A” for Attached payloads or
“P” for Pressurized payloads.  This character is automatically assigned when the
payload is created as an Attached or Pressurized payload.

2.3 SCHEDULE OF DATA ENTRY

The required data entry completion for each Data Set will vary and is determined
individually by each integration discipline.  The template for most payloads’ initial data
promotion (data entry complete) is L–24 months.  This template will be reduced periodically as
the Space Station program nears Assembly Complete.  A generic PDL template is shown in
Figure 2–2.

FIGURE 22  PDL DATA ENTRY TEMPLATE

Tactical Planning
Requirements 

Input

Disp.1

Disp.2

Disp.3

Disp.4

Disp.5

Disp.6

Payload Discipline Inputs

EI POIF

PSIV

PL Systems Engineer
Input

L-0

PL Integration
Begins

TPS

L-XL-Y

CMIL-PUMDB POIC

KSCOthers

L-K

Baseline of 
PL Data

L-Z

PDL Initialization
from UMDB

User Account RequestPayload Agreement

Promote Datato �Integrated"

Promote Datato �Controlled"

2.4 DATA DISTRIBUTION

There are several end users that utilize payload information collected in the Space
Station PDL. These end users will receive this information via database exports or File
Transfer Protocols (FTP).  The responsible group and PDL will work with end users to create
an Interface Agreement Document (IAD) or an Interface Control Document (ICD) to specify the
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format of the data to be transferred and the method of transfer.  The following documents have
been developed with end users:

A. Huntsville Operations Support Center (HOSC) to E&OI PDL ICD (ICD–3–60056)

B. Payload Software Integration and Verification (PSIV) to PDL IAD (D683–21415–1)

C. Kennedy Space Center (KSC) to PDL IAD (TBD)

D. Consolidated Management, Inventory, and Logistics Planning (CMILP) to PDL IAD
(TBD)

E. PDL/Payload Tactical Planning Tools to Mission Management Data System (MMDS)
IAD (SSP TBD).
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SECTION 3,  USING THE PAYLOAD DATA LIBRARY

3.1 LOGGING ON

When the PDL Client Software is launched by double–clicking the PDL Client icon, the
first screen will ask you to log on to the PDL Server.  This screen consists of two fields
(Username and Password) and three buttons (Cancel, New Password, and Logon).  Clicking
the Cancel button will exit the PDL Client Application, while the Logon button will attempt to
log you on to the PDL Server using the Username and Password entered.

The first time you access PDL, the temporary password from the “PDL Welcome
Newsletter” will expire and you will be required to enter a new password.  From that point
forward, the password will expire automatically at the beginning of every month.  Figure 3–1
depicts the logon screen and field entries.  To change your password, click the New Password
button.  Figure 3–2 shows the logon screen in the change–password mode.  Two new fields
(New Password and Verify Password) and a new button (No Change) will appear.  If you

FIGURE 3-1  LOGGING ON
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decide not to change your password, click the No Change button.  Otherwise, enter your new
password in both of these fields and click the Logon button to change the password and
connect to the PDL server.

FIGURE 3-2  CHANGING A PASSWORD

3.2 SELECTING A PAYLOAD

Once you have successfully logged on to the PDL Server, the PDL Main Screen will
appear.  The Main Screen, shown in Figure 3–3 is easily recognized by the large PDL logo and
the Payload Selection Pop–up Box at the bottom of the screen.  The payload that appears in the
Payload Selection Pop–up Box is selected by default.  Whenever a new payload is selected, the
Payload ID, Payload Acronym, and Payload Sponsor fields will display below the Payload
Selection Pop–up Box for 10 seconds.

If you need to work on a payload other than the default payload, move the cursor to the
Payload Selection Pop–up Box, as shown in Figure 3–4, click and hold to expand the list, then
drag the cursor to the desired Payload and release.
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FIGURE 3-3  UNDERSTANDING THE MAIN SCREEN

Once a payload has been selected, you may select the desired Discipline, Option, and
Form from the menu at the top of the screen.

3.3 UNDERSTANDING THE MENU SYSTEM

The PDL Client menu consists of File, Edit, Disciplines, Option, Forms, and Help
choices as shown in Figure 3–5.  The pull–down items under the File menu include Import,
Export, Reports, Promote, Print, and Quit functions. The Import and Export functions are
discussed in Section 3.11; the Reports function, in Section 3.6; and the Promote function in
Section 3.10.  The Print function captures and prints the current screen; the Quit function exits
the PDL application.
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FIGURE 3-4  SELECTING A PAYLOAD 
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FIGURE 3-5  UNDERSTANDING THE MAIN MENU
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3.3.1 Navigating Through Disciplines

Each PDL data entry screen is selected by navigating through a three–level hierarchy.
Therefore, you must identify a particular Discipline, Option, and Form in order to reach a
desired data entry screen.   Since the PDL navigating system is governed by Discipline within a
Payload, you must first select your discipline after logging on to the PDL and selecting
payload.  To display the discipline list, position the cursor on the Discipline menu and pull
down the discipline list as shown in Figure 3–6.

FIGURE 3-6  SELECTING A DISCIPLINE
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3.3.2 Navigating Through Options

Once the discipline is identified, the Option menu will automatically be populated based
on that selected discipline.  Option is a logical grouping of data entry forms.  To display the
option list, position the cursor on the Options menu and pull down the option list as shown in
Figure 3–7.  This example is under the Systems–PL discipline.

FIGURE 3-7  SELECTING AN OPTION
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3.3.3 Navigating Through Forms

If the selected option is Flight, Rack, POP, or Subpayload Element associated, another
screen will pop up.  For instance, if you select Payload Rack On–Orbit Placement
Requirements under the Option pull–down menu, the Flight and Rack Selection Screen pops
up as shown in Figure 3–8.  You select the Flight you would like to work on from the upper

FIGURE 3-8  SELECTING A FLIGHT AND/OR RACK OR POP

part of screen.  All racks for the selected flight will be listed in the lower part of the screen as
shown in Figure 3–8.  Click OK when finished.  Pressing the Cancel button will deselect the
option and return to the main screen.  You may then reselect your desired Discipline and
Option.

The forms menu will automatically be populated once an option is selected.  The group
of forms retrieved is based on the selected discipline and option.  Selecting a form from the
Form pull–down menu retrieves the form and its associated data from the database for display.
An example of a Form Menu is shown in Figure 3–9.
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FIGURE 3-9  SELECTING A FORM

3.3.4 Cross–Discipline Navigating

If you work on a form across various disciplines, you can jump from one discipline to
another without leaving the form.  You can leave the form open and select different disciplines.
PDL will automatically retrieve the applicable items based on the selected discipline.  If the
selected discipline does not apply to the selected form, PDL returns to the main screen where
you can reselect Option and Form as you desire.
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3.3.5 Accessing Help/News from Menu

In addition to the Help button on the lower right corner of a Form screen (as in Figure
3–11), the Help menu allows you to access help information as shown in Figure 3–10.  Help is
discussed in detail in Section 3.7.  News items can be also be selected from the Help menu.  A
detailed description of News is given in Section 3.8.

FIGURE 3-10  SELECTING HELP/NEWS
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3.4 UNDERSTANDING THE STATUS LINE

The status line, depicted in Figure 3–11, at the top of the PDL Form screen displays the
selected Discipline, Option, and Flight.  The far right field shows the selected Rack or POP
when appropriate.  The status line also displays the selected payload, the original author and
creation date of the form, the author and date of the latest change to the form, and the
configuration control level.

FIGURE 3-11  UNDERSTANDING THE STATUS LINE

Selected Discipline Selected Option Selected flight Selected Rack or POP

Selected Payload

Original Author

Create Date

Author and date of latest change
Control Level
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3.5 UNDERSTANDING THE LAYOUT BUTTONS

All Forms layouts have buttons at the bottom of the screen, as shown in Figure 3–12.
Each button has its own unique function that is easily executed by a single click.  The buttons
from left to right are:

CANCEL – Exits the Form and returns to the PDL Main Screen.
REVERT – Deletes any changes that have been made to the current form    since the last save.   

PREVIOUS –  Navigates to the previous Form in the Forms menu list and is disabled when the first
Form in the list is selected.
NEXT –  Navigates to the next Form in the Forms menu list and is disabled when         the last Form
in the list is selected.
UPDATE –  Saves all changes made to the current Form.
HELP – Invokes item–specific Help for items on a Form.
ADD/DELETE – Appears conditionally when applicable, adds or deletes records shown on screen.

FIGURE 3-12  UNDERSTANDING THE LAYOUT BUTTONS
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3.6 VIEWING THE REPORTS IN PDL

To view reports in PDL, select Reports from the File menu.  Highlight a Report Title in
the Report selection window to select it.  You can also search for a key word by entering it in
the Find box.  In the Runtime Parameter form, set the Report parameters by choosing from the
pop lists, then click the Run Report button.

3.7 USING THE PDL HELP

3.7.1 Item–Specific Help

To access Item–specific Help, place the cursor in the appropriate field, then click the
Help button. See Figure 3–13.

FIGURE 3-13  ACCESSING ITEM-SPECIFIC HELP

Place the cursor in the field for which Help is desired.

Click the Help button.
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The Help for the selected field will be displayed.  See Figure 3–14.  Click Done when
finished.

FIGURE 3-14  VIEWING ITEM-SPECIFIC HELP

3.7.2 Form–Specific Help

To access Form–Specific Help, choose On Forms from the Help menu.  All PDL
options are displayed.  (Note: This is not discipline specific.)  Choosing an Option will display
Help and a list of forms for the selected Option.  See Figure 3–15.  If the user selects a Form,
the Option Help is replaced by Form Help.  See Figure 3–16.  Click Done when finished.

3.7.3 General Help

To access General Help, choose General from the Help menu.  Enter a keyword in the
text box and click the Find button.  A list of matching items will be displayed in the first scroll
box.  Items in the list contain the keyword in the title or in the help text.  Select an item from
this box and the associated Option title, Form title, Field title, and Help text will be displayed.
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See Figure 3–17.  Click Done when finished.

FIGURE 3-15  VIEWING OPTION-SPECIFIC HELP

1. Select an Option

2. The Help for the selected Option is displayed.

3. Click Done when finished.
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FIGURE 3-16  VIEWING FORM-SPECIFIC HELP

1. Select an Option

3. The Help for the selected Form is displayed.

4. Click Done when finished.

2. Select a Form from the forms list for the selected Option.
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1. Enter a keyword
2. Click the Find Button

3. Highlight an Option

4. Click Done when finished.

FIGURE 3-17  VIEWING GENERAL HELP
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3.7.4 Sending Comments to the PDL Team

To send comments to the PDL Team, choose Review Comments from the Help menu
and click the Add button.  Your user name, current date, current version number, computer
platform, current discipline title, current option title, current section title, and the next Comment
ID number will be automatically entered into the record.  You may then type in a message,
comment, question, or problem in the description field (this is the only field that the user can
update).  Click the Update button to send the comment to the PDL team or click the Revert or
Cancel button to erase the comment.  Use the Comment ID number to check the status of and
the PDL response to your comment.  See Figure 3–18.

FIGURE 3-18  SENDING COMMENTS TO THE PDL TEAM
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3.8 ACCESSING THE LATEST PDL NEWS ITEMS

PDL News, shown in Figure 3–19, is available by selecting News from the Help
menu.  The current PDL version number is displayed as well as informative messages from the
PDL development team.  Click the Done button to close the News window.

Current Version
Date of message

Click to close

FIGURE 3-19  VIEWING PDL NEWS
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3.9 ENTERING INFORMATION INTO THE PDL

There are several ways to enter information into PDL.  Any constraints on data length
or format are displayed in the Hint Line at the bottom of the screen and in the Item Help
information available from the Help menu.  After entering information, click the Update button
on the bottom of the screen to save changes.

Select items in a list by clicking in a checkbox as shown in Figure 3–20.

1. Click all that apply.

2. Click the Update button to save changes.

FIGURE 3-20  ENTERING INFORMATION WITH A CHECKBOX
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Enter quantities by placing the cursor in the white entry field and typing the information,
shown in Figure 3–21.

1. Click in field and type

2. Click the Update button to save changes.

FIGURE 3-21  ENTERING INFORMATION IN SHORT FIELDS
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Enter long descriptions and comments by placing the cursor in the large white entry
field and typing all text, as shown in Figure 3–22.  A scroll bar at the right edge of the field
facilitates text scrolling.  Text can also be navigated by using the Up and Down arrow keys.

1. Click in field and type.

2. Click the Update button to save changes.

FIGURE 3-22 ENTERING LONG DESCRIPTIONS
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To add an entry, such as an additional item to a list of predefined items, first click the
Add button, as shown in Figure 3–23.  After entering the new information, click the Update
button to save changes.

1. Click the Add button first.

2. Then click in field and type.

3. Then click the Update button to save changes.

FIGURE 3-23  ENTERING INFORMATION BY ADDING A RECORD

3.10 PROMOTING DATA

TBD

3.11 IMPORTING GRAPHICS

TBD



D683–35473–1

3-24

(This Page Intentionally Blank)



D683–35473–1

A_i

APPENDIX A

ABBREVIATIONS AND ACRONYMS
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APPENDIX A,   ABBREVIATIONS AND ACRONYMS

C Commercial or Canadian Space Agency
Cmd. Command
CMILP Consolidated Management, Inventory, and Logistics Planning
CSA Canadian Space Agency

Disp. Discipline

E&OI Engineering and Operations Integration
EMI Electromagnetic Interference
ESA European Space Agency

FTP File Transfer Protocol

GUI Graphical User Interface

HOSC Huntsville Operations Support Center

IAD Interface Agreement Document
ICD Interface Control Document

KSC Kennedy Space Center

L Launch

MB Megabyte
MHz Megahertz
MMDS Mission Management Data System
MSFC Marshall Space Flight Center

NASA National Aeronautics and Space Administration
NASDA National Space Development Agency of Japan

PC Portable Computer
PDL Payload Data Library
PL Payload
POIF Payload Operations Integration Function
POP Payload Operation Performance
PSIV Payload Software Integration and Verification

RAM Random Access Memory
RDBMS Relational Database Management System



D683–35473–1

A_2

SPOE Standard Payload Outfitting Equipment
SSP Space Station Program
STS Space Transportation System

TBD To Be Determined
TCP/IP Transmission Control Protocol/Internet Protocol

UMDB User Mission Database

WWW World Wide Web


